Just sharing my experience
Results 1 to 6 of 6

Thread: Just sharing my experience

  1. #1
    Active Member
    Join Date
    Jan 2019
    Location
    Barrie,ON
    Posts
    60

    Default Just sharing my experience

    Just sharing my experience in the last few days.
    Whom seen my older post from a few days a go I made a rookie mistake and f up my drain plug(only the rear).
    So went out there to look for the best "kit" to fix it.
    New pan is about 226CAD +TAX from the dealer
    There quite a few kits out there to repair stripped threads(helicoil)but the one I end up used is made for spark plugs.
    The kit is basic and straightforward
    First used the tap to retap the original hole with a good amount of grease so all shavings will stick in it,the tap have 2 steps,the second step is the actual thread for the helicoil,but instead of going all the way in,I did it step by step 2-3 thread at the time,pulled the taped out cleaned the dirty grease with the shavings,regrease and in again.
    After a few times the thread in nice and clean,all the way.
    Put some harder gasket on the helicoil and in
    The last tool it's to punch in the coils and all done

    Sorry for the creepy English.



    Sent from my SM-N960W using Tapatalk

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    Very Active Member NoSetFine's Avatar
    Join Date
    Apr 2017
    Location
    Ontario, Canada
    Posts
    895

    Default

    WHEW, right??
    Glad that worked. Hopefully it holds.
    Good to know for if I ever do the same.


  4. #3
    Very Active Member
    Join Date
    Nov 2015
    Location
    Winter Florida, Summer Kentucky
    Posts
    526

    Default

    Thanks for the info. I will try to find this thread if I have the same problem. It would help if the tread titles matched the content.

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Very Active Member FlyingCircus's Avatar
    Join Date
    Dec 2016
    Location
    Saskatchewan Canada
    Posts
    2,775

    Default

    Glad it all worked out for you. Hoping I never have that problem but one never knows

  7. #5
    Very Active Member W8INLINE's Avatar
    Join Date
    Aug 2015
    Location
    Canada
    Posts
    157

    Default

    Where did you get that kit from?
    <img src=https://www.m109riders.com/forums/signaturepics/sigpic65778_1.gif border=0 alt= />

  8. #6
    Active Member
    Join Date
    Jan 2019
    Location
    Barrie,ON
    Posts
    60

    Default

    Quote Originally Posted by W8INLINE View Post
    Where did you get that kit from?
    Amazon.ca

    Helicoil 5334-14 Save-A-Thread Thread Repair Kit M14 x 1.25 https://www.amazon.ca/dp/B0002SRF4O/..._x31hDbM6Z0V9E

    Sent from my SM-N960W using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •