High RPM’s and exhaust popping
Results 1 to 6 of 6

Thread: High RPM’s and exhaust popping

  1. #1

    Default High RPM’s and exhaust popping

    Hi All, I have a 2007 M109R , recently I’ve been experiencing High RPM’s and exhaust popping. The bike is revving go 2k at in neutral with consistent exhaust popping. Any ideas of what my be causing this? I replaced all of the spark plugs hoping that would solve the issue but no luck. Any help will be greatly appreciated. David 443-623-6892

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2

    Default

    High RPM’s and exhaust popping
    Hi All, I have a 2007 M109R , recently I’ve been experiencing High RPM’s and exhaust popping. The bike is revving to 2k ROM in neutral with consistent exhaust popping. Any ideas of what my be causing this? I replaced all of the spark plugs hoping that would solve the issue but no luck. Any help will be greatly appreciated. David 443-623-6892

  4. #3
    Very Active Member UVATom's Avatar
    Join Date
    Jun 2018
    Location
    Concord, VA
    Posts
    181

    Default

    Are you saying it's revving itself up to 2k and popping? Check your air filters. I know when I put the rain socks on mine it tends to idle a little higher and a tad rougher.
    Last edited by UVATom; 06-24-2019 at 06:51 PM.

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Very Active Member FlyingCircus's Avatar
    Join Date
    Dec 2016
    Location
    Saskatchewan Canada
    Posts
    2,775

    Default

    Quote Originally Posted by UVATom View Post
    Are you saying it's revving itself up to 2k and popping? Check your air filters. I know when I put the rain socks on mine it tends to idle a little higher and a tad rougher.

    Hmm. First I've heard someone say that. My idle is higher, 1100 to 1200 and just since I added the prechargers. I thought maybe it was the ECU Flash. I did them both at the same time. So they are maybe to restrictive?. Good news as if I take them off I could gain a couple 10ths off my quarter mile time

  7. #5
    Very Active Member UVATom's Avatar
    Join Date
    Jun 2018
    Location
    Concord, VA
    Posts
    181

    Default

    Quote Originally Posted by FlyingCircus View Post
    Quote Originally Posted by UVATom View Post
    Are you saying it's revving itself up to 2k and popping? Check your air filters. I know when I put the rain socks on mine it tends to idle a little higher and a tad rougher.

    Hmm. First I've heard someone say that. My idle is higher, 1100 to 1200 and just since I added the prechargers. I thought maybe it was the ECU Flash. I did them both at the same time. So they are maybe to restrictive?. Good news as if I take them off I could gain a couple 10ths off my quarter mile time [IMG class=inlineimg]https://www.m109riders.com/forums/images/smilies/drool.gif[/IMG]
    It is the socks on my bike. Just removing them doesn't fix it if the bike is started with them on. I have to cut the bike off and restart it for it to clear up but I also have an Fi tuner too.

  8. #6
    Very Active Member UVATom's Avatar
    Join Date
    Jun 2018
    Location
    Concord, VA
    Posts
    181

    Default

    You have probably already figured this out but it just happened to me this morning. Bad gas. Took a different route to work this morning and stopped to get gas on the way. I even thought twice before pulling in due to the neighborhood but did it anyway. As soon as I cranked it up it went to 2k and stayed. I'll be draining it this evening. All these years have been using the same three stations except when out of town. Never again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->