c90 engine in a m90
Results 1 to 3 of 3

Thread: c90 engine in a m90

  1. #1
    Very Active Member gavs90's Avatar
    Join Date
    Mar 2009
    Location
    australia
    Posts
    739

    Default c90 engine in a m90

    so guys i just finished swapping my 78000klm 2009 m90 engine for a 2015 c90 boss engine with 8000klms the only issue i had was with the throttle bodys the 2015 doesnt have pipes running to a sensor on the throttle grip side like the m90. so i couldnt fit the 2015 body but I put the coils and fuel pump from the 2015 on too. I had to take a cover off that sits over the filter to fit but the filters are half the price. im very happy I swapped motors as the 2015 is quieter and less vibration than the old motor will post some pics of the bike finished soon. the reason I changed motors was because of the klms but also the bike ran very lean one weekend and I had to ride it home. im fairly sure the powercommander5 **** it self had been on there for 8 years
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0034.jpg 
Views:	25 
Size:	107.1 KB 
ID:	382932   Click image for larger version. 

Name:	IMG_0041.jpg 
Views:	25 
Size:	88.8 KB 
ID:	382934   Click image for larger version. 

Name:	IMG_0038.jpg 
Views:	26 
Size:	113.7 KB 
ID:	382938   Click image for larger version. 

Name:	IMG_0042.jpg 
Views:	22 
Size:	74.3 KB 
ID:	382936  
    Last edited by gavs90; 04-03-2019 at 02:27 AM.
    240 rim cobra swepts cobra tacho rifle windsheild & lowers led turnsignals v charger air filters chrome radiator cover 1 1/2 inch lowering bones powercommander 5 glpro

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    Very Active Member gavs90's Avatar
    Join Date
    Mar 2009
    Location
    australia
    Posts
    739

    Default

    decided to put the bike back stock as i dont have a fuel management at this time and tell the truth other than loudness from the pipe i cant tell the difference in power
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0052.jpg 
Views:	24 
Size:	117.0 KB 
ID:	382962   Click image for larger version. 

Name:	IMG_0048.jpg 
Views:	21 
Size:	119.0 KB 
ID:	382966  
    240 rim cobra swepts cobra tacho rifle windsheild & lowers led turnsignals v charger air filters chrome radiator cover 1 1/2 inch lowering bones powercommander 5 glpro

  4. #3
    Very Active Member gavs90's Avatar
    Join Date
    Mar 2009
    Location
    australia
    Posts
    739

    Default

    so I was still having a slight miss and the bike bogging down at very little throttle turn I knew it wasn't the fuel filter, motor, coils, throttle bodies as I just changed all them and the old motor was doing the same thing. so I tried disconnecting the glpro gear indicator and its looking as though this was the problem the bike is running great at this time like a whole new bike. the gear shifting is even better still has the clunk but that's normal and so much torque. I may put the pcv back on to see if its working still so I can have my tacho back and because I had just brought a new lcd screen for the pcv that cost me $500 aus
    240 rim cobra swepts cobra tacho rifle windsheild & lowers led turnsignals v charger air filters chrome radiator cover 1 1/2 inch lowering bones powercommander 5 glpro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •