Possible fuel problem
Results 1 to 7 of 7

Thread: Possible fuel problem

  1. #1
    Member
    Join Date
    Mar 2019
    Location
    kalamazoo Mi
    Posts
    5

    Unhappy Possible fuel problem

    Hey guys new to the forum but definitely liking it so far. So I have a 06 m109 with 7k miles. The problem is when I hammer on the throttle at about 3k rpm the bike hesitates unless I pull back on the throttle. Recently I changed my spark plugs but that didn't seem to fix it. Also been running seafoam through and nothing as well. Currently, the bike has no power commander and only has k&n air filters and cobra exhaust with baffles still in. Any ideas?

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #2
    Very Active Member Bering_C_Sparky's Avatar
    Join Date
    Jun 2017
    Location
    Florida
    Posts
    2,878

    Default

    What kind of "Cobra" pipes do you have?

    BCS

  4. #3
    Very Active Member M109Dreamer's Avatar
    Join Date
    Jul 2008
    Location
    Forney, TX
    Posts
    6,743

    Default

    What gear are you in when you go WOT?

    Try it at 3500 rpms or higher. 3000 rps is still kinda lugging the motor.

    Sent from my SAMSUNG-SM-G920A using Tapatalk

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #4
    Member
    Join Date
    Mar 2019
    Location
    kalamazoo Mi
    Posts
    5

    Default

    Quote Originally Posted by Bering_C_Sparky View Post
    What kind of "Cobra" pipes do you have?
    BCS
    They are two into one

  7. #5
    Member
    Join Date
    Mar 2019
    Location
    kalamazoo Mi
    Posts
    5

    Default

    Quote Originally Posted by M109Dreamer View Post
    What gear are you in when you go WOT?

    Try it at 3500 rpms or higher. 3000 rps is still kinda lugging the motor.

    Sent from my SAMSUNG-SM-G920A using Tapatalk
    This occurs throughout all gears. As soon as I hit 3k it sputters but if i roll off the throttle it will accelerate

  8. #6
    Very Active Member M109Dreamer's Avatar
    Join Date
    Jul 2008
    Location
    Forney, TX
    Posts
    6,743

    Default

    Quote Originally Posted by zoocko12 View Post
    This occurs throughout all gears. As soon as I hit 3k it sputters but if i roll off the throttle it will accelerate
    I am leaning fuel filter. Have you ever changed yours yet?

    Sent from my SM-T580 using Tapatalk

  9. #7
    Member
    Join Date
    Mar 2019
    Location
    kalamazoo Mi
    Posts
    5

    Default

    No I have not. Gonna order one tonight and see how that works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •