Fi2000 settings--please share - Page 3
Page 3 of 5 FirstFirst 12345 LastLast
Results 61 to 90 of 142

Thread: Fi2000 settings--please share

  1. #61
    vapiper
    Guest

    Default

    Cobra swept/stock air

    Currently at preset 1-3-2
    Going to bump it to 2-3-2 and see what that does....have only had this setup on for two days and havn't really had a chance to put her through the paces..so far runs excelent...have had a slight pop once, or twice on decelleration....but it would do that in the stock form once in a while as well......

    the "manual" says to adjust each "pot" individually and instructions on what to look for on each...so...will just have to play with it and I'll repost my final settings when I can.

  2. Remove Advertisements
    M109Riders.com
    Advertisements
     

  3. #62
    Very Active Member LuciousBlvd's Avatar
    Join Date
    Nov 2008
    Location
    Clearwater, FL
    Posts
    142

    Default

    I have mine currently at 2-3-2 and its still a pita to roll on the throttle easily it did seem to get rid of the intake fires, but still have lots of decel pop..

    i still need to block the pair valves and remove the s.e.t vlave cables, and install my K&N's.

    Stock shorties and "duck" style mod..

    Quote Originally Posted by bullrider View Post
    thick shmoopucky(technical term for gunk)

  4. #63
    vapiper
    Guest

    Default

    At 2-3-2 now, dosn't decell pop as much as it did, but still a little there....

    I guess I need to go up a little higher? on the first pot

  5. Remove Advertisements
    M109Riders.com
    Advertisements
     

  6. #64
    Very Active Member Gramps's Avatar
    Join Date
    Sep 2007
    Location
    small ranch/farm out in the country 10 miles north of Burlington N.C.
    Posts
    3,719

    Default

    Quote Originally Posted by vapiper View Post
    At 2-3-2 now, dosn't decell pop as much as it did, but still a little there....

    I guess I need to go up a little higher? on the first pot
    I have never had decell popping so I am not an expert on your situation,however if your running Cobra Swepts with stock air intake or even K&N's thru the stock boxes,I cannot see how you would need it more then 1 to 1.5 on the first pot and any more then 2 would seem too rich...but try it and see...you can always turn it back. I was under the impression decell popping was from too much air entering the combustion chamber when the fuel flow is shut down. I might go up one more on the 3rd pot overall adjustment and back the first pot down to 2 or even 1 if it doesn't work out your way.

  7. #65
    Radio Active Member Zoom's Avatar
    Join Date
    Mar 2007
    Location
    West Virginia
    Posts
    22,464

    Default

    Quote Originally Posted by vapiper View Post
    At 2-3-2 now, dosn't decell pop as much as it did, but still a little there....

    I guess I need to go up a little higher? on the first pot
    As Gramps said, the fuel adjustment won't stop the popping. It may even make it worse if you add more fuel as the popping is caused when unburnt fuel ignites in the exhaust.

    Two things cause it and can be fixed.

    One is the PAIR valves, which admits air into the exhaust under deceleration. Block them and that usually stops the popping.

    The other is an exhaust leak. Any leak that can let air in can cause decel popping. The most common place for a leak is the connection to the heads.






  8. #66
    vapiper
    Guest

    Default

    Quote Originally Posted by Zoom View Post
    As Gramps said, the fuel adjustment won't stop the popping. It may even make it worse if you add more fuel as the popping is caused when unburnt fuel ignites in the exhaust.

    Two things cause it and can be fixed.

    One is the PAIR valves, which admits air into the exhaust under deceleration. Block them and that usually stops the popping.

    The other is an exhaust leak. Any leak that can let air in can cause decel popping. The most common place for a leak is the connection to the heads.
    thanks gang...will try that out and see what happens....it's not doing it enough to be a major concern...but if I can eliminate it, it would be nice I'm sure just some minor tinkering and all will be good....

  9. #67
    Very Active Member z71cad's Avatar
    Join Date
    Dec 2007
    Location
    channelview, texas 77530
    Posts
    407

    Default

    read alot of different settings trying to decide which one is the best, im running shortenend gutted exhaust, gutted cat, big air kits and a tre, my settings are 1-4-2 which is the way it was set before i chopped exhaust and added air kits, seems to run rich but is jerky on the take off, which way should i go to try and smooth it out some??
    Robert Booty

    "I WOULD RATHER BE AN OPEN SINNER THAN A FALSE SAINT"


  10. #68
    vapiper
    Guest

    Default

    at 1-2.5-2....seems the more I bump up any, the more backfiring I get....so..this is about right....I'll do the TRE when I get back from bike week as most of it seems to happen during the hesisatation that occurs in 1,2,3rd.....

  11. #69

    Default

    ok I guess it's time I said my peice cuz I've been havin issues too. I do think 109's have condensation issues in the tank ( I live in VT) cuz I have to use dry gas to keep it from stalling at a stop sign in spring and fall, a tiny bit of dry gas fixes that problem instantly. Then I went with Cobra swept exhaust, K&N filters and a pc3. In hot weather I had sporadic issues, poor acceleration when wringin it and sometimes after it was running ok I'd park it for a bit, then when I got back on it would start right up but didn't want to move, a scooter could out run it! After 2 pc3's I had an fi2000 put on, then in hot weather it wouldn't rev up over 2 grand but wouldn't stall either...I think my biggest problem may have been that my mechanics were puttin these fuel controllers on with the factory settings (1-2.5-1.5 was where mine was at out of the box for the fi2000) and calling it good enough. After readin what some people here had to say I took matters into my own hands and put the thing at 2-3-2 based on what someone else said here who had the same exhaust/filter set up. Tell ya what I had to change my shorts after wringin out fourth gear with that setting! I think I'll still try to find a shop with a dyno tho....and I have been smellin gas when I come to a stop always since the pipes got put on....also gotta see what happens on a hot day cuz I can't remember the last time I heard my fan runnin....can anyone tell me how to check that out myself? Thanks for listenin, Charley

  12. #70
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    bumping to the top for new people.

  13. #71
    Active Member
    Join Date
    Jun 2009
    Location
    Fort Erie,Ontario,Canada
    Posts
    53

    Default

    Cobra Dragsters with quiet baffles,K&N's in stock air boxes

    Elev about 600 ft ASL

    1-3-2 and running good

    Dave


  14. #72
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    bump the last 2 pods up .5 or 1 i bet it runs better.

  15. #73
    Very Active Member Tiny71's Avatar
    Join Date
    Apr 2008
    Location
    point marion,pa
    Posts
    501

    Default

    i finally got mine set.i'm running 2.5,3,3 and it purrs like a kitten. for anyone having popping or rough running off of idle check your wiring. check the ground wire at the crimp on the ring connector (mine wasn't crimped good). also pop the cover off and check the plug where wires come into the unit. it is hot glued from factory but i had mine pull apart twice causing bike to run like crap! decel pop, hesitation,stuttering etc.

  16. #74
    Member
    Join Date
    Apr 2010
    Location
    Mississauga, Ontario Canada
    Posts
    11

    Default Just getting mine

    I just ordered mine and I currently have.
    Holley Air and the standard factory pipes that have been drilled...
    Like to know if any one has that setup if so what you have your Fi2000r set to...

  17. #75
    Very Active Member up@12's Avatar
    Join Date
    Sep 2008
    Location
    Breslau, Ontario
    Posts
    398

    Default

    Sideburner 2 into 1 exhaust
    K&N filters
    TRE
    My cobra is set to 2-3-2 and runs great

    Sideburner Exhaust, Lowered 2", K&N Filters, TRE, Power Commander, Raw Rear Turn Signals, Raw Side Mount Licence Plate, Low & Mean Chin, Irate Mess Grill with matching chin mess. CM Legacy rims 280 on the rear and 160 up front, More to come!!!!

  18. #76

    Default

    I'm at about 2300 ft here in Idaho, I've got Xtreme Revolution Ultra Flow air cleaners and Cobra Dragsters. I'm getting a lot of missing and surging around 3200 - 3900 rpm. Anyone else have a similar setup and an idea of what settings I should be going with?

  19. #77
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    what are your settings now? default??

  20. #78

    Default

    I'm at about a 1-2-1 right now. I don't like the way its running at all

    UPDATE - just checked the plugs and I definitely need more fuel, I just don't know which pot to tune the 3-4K RPM range

  21. #79
    Very Active Member Gramps's Avatar
    Join Date
    Sep 2007
    Location
    small ranch/farm out in the country 10 miles north of Burlington N.C.
    Posts
    3,719

    Default

    The first pot controls the idle to lower rpm range and light throttle loads,the second pot acts like an accelerator pump for medium to full throttle ,and the third pot is like a main jet for adding overall fuel throughout the rpm range. Generally mine runs best at 2 or 2.5/4/2.

  22. #80
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    Quote Originally Posted by paulyester View Post
    I'm at about a 1-2-1 right now. I don't like the way its running at all

    UPDATE - just checked the plugs and I definitely need more fuel, I just don't know which pot to tune the 3-4K RPM range
    i would bump them to 3-4.5-4 with your air kit and you alt that should send enough fuel.

  23. #81
    Member tesnevo's Avatar
    Join Date
    Aug 2009
    Location
    Nashville, TN
    Posts
    27

    Default Help with settings for mine

    Any suggested settings for mine, it has the D&M Custom Cycles Power flow intakes

    http://www.dmcustomcycle.com/product...ct=PF-6100-SCH


    and the cobra swept exhaust.

    I have a pc3 on it (was free) but truthfully dont want to pay 400.00 to dyno it.
    Thanks.
    Last edited by tesnevo; 08-15-2010 at 05:48 PM.
    "If you cant change your team, then change your team!"

  24. #82
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    Quote Originally Posted by tesnevo View Post
    Any suggested settings for mine, it has the D&M Custom Cycles Power flow intakes

    http://www.dmcustomcycle.com/product...ct=PF-6100-SCH


    and the cobra swept exhaust.

    I have a pc3 on it (was free) but truthfully dont want to pay 400.00 to dyno it.
    Thanks.

    so do you have PC3 or the cobra unit??

  25. #83
    Member tesnevo's Avatar
    Join Date
    Aug 2009
    Location
    Nashville, TN
    Posts
    27

    Default

    I have the pc3 on there now. Not really happy with it due to it seeming to stumble under acceleration. It still runs great and great mpg I just dont feel its set correctly enough w/o a dyno. And like I said dont want to fork over 400.00 to do it. Im ordering the fi2000r tomorrow morn.
    I am curious as to if the fi2000r would perform better than the pc3.
    "If you cant change your team, then change your team!"

  26. #84
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    i like it better. its cheaper more user friendly and more tunable without the need of a tuner.

  27. #85
    Member tesnevo's Avatar
    Join Date
    Aug 2009
    Location
    Nashville, TN
    Posts
    27

    Default

    Any settings suggestion for my setup? Or maybe I just need to custom dyno the girl and be done...
    "If you cant change your team, then change your team!"

  28. #86
    Very Active Member pynikal's Avatar
    Join Date
    Jan 2008
    Location
    Blue Springs, MO
    Posts
    4,485

    Default

    look for some one with tornadoes and sweeps. that would be about the same.

  29. #87
    Very Active Member Tbud's Avatar
    Join Date
    May 2009
    Location
    Wake Forest, NC
    Posts
    2,164

    Default

    Try setting the FI2000R pots to 2-4-3. With the Roadhouse pipes, K&Ns and FI2000R, you should see a gain of at least 10HP.

  30. #88
    Very Active Member devilr1's Avatar
    Join Date
    Jul 2009
    Location
    Breslau.On
    Posts
    1,218

    Default

    Guys, I got Scorpion tips, K&Ns and FI2000R. It is running good ,but I know it could be better. I have some popping issues too.
    Right now it is 3.5-5-2.5
    I tried the 2-3-2 and played with it a few times, but not really sure which way to go with it. Any suggestions would be greatly appreciated.

  31. #89
    Very Active Member Tiny71's Avatar
    Join Date
    Apr 2008
    Location
    point marion,pa
    Posts
    501

    Default

    got a little tid bit of info on the fi 2000 that helped me. in the instructions it says to put the ground on the battery -. a buddy told me to ground it to the chassis. took it for a ride and can tell a difference, especially when i open the throttle up. no more hesitation or "building" up it is right there when you hit the throttle. he explained it about what happens i'm not even going to try to repeat it. i just know it helped.

  32. #90
    Very Active Member Tiny71's Avatar
    Join Date
    Apr 2008
    Location
    point marion,pa
    Posts
    501

    Default

    Quote Originally Posted by devilr1 View Post
    Guys, I got Scorpion tips, K&Ns and FI2000R. It is running good ,but I know it could be better. I have some popping issues too.
    Right now it is 3.5-5-2.5
    I tried the 2-3-2 and played with it a few times, but not really sure which way to go with it. Any suggestions would be greatly appreciated.
    i posted this before. check your ground wire end connector,and check the connection in the box itself. hot glue not the strongest thing in the world. i think i pulled mine apart when i put the seat on,caught the wire harness.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->